Chelsio T6225-CR and SM10G-SR

I finally got my two Chelsio SM10G-SR SFP+ optical modules. First light have finally been achieved.

cc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=ec07bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        ether 00:07:43:XX:XX:X0
        hwaddr 00:07:43:XX:XX:X0
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-SR <full-duplex,rxpause,txpause>
        status: active

/etc/rc.conf has been prepared and the system will be rebooted later today. That will enable the use of cxgbe(4) and cxgbev(4). The use of ccr(4) will have to wait until stable/12 exist.

cc0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=ec07bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        ether 00:07:43:XX:XX:X0
        hwaddr 00:07:43:XX:XX:X0
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-SR <full-duplex,rxpause,txpause>
        status: active
        supported media:
                media 10Gbase-SR mediaopt full-duplex,rxpause,txpause
                media 10Gbase-SR mediaopt full-duplex,rxpause
                media 10Gbase-SR mediaopt full-duplex,txpause
                media 10Gbase-SR mediaopt full-duplex
                media 1000baseSX mediaopt full-duplex,rxpause,txpause
                media 1000baseSX mediaopt full-duplex,rxpause
                media 1000baseSX mediaopt full-duplex,txpause
                media 1000baseSX mediaopt full-duplex
        plugged: SFP/SFP+/SFP28 10G Base-SR (LC)
        vendor: JDSU PN: PLRXPLSCS4342B SN: CJ28XXXXX DATE: 2018-07-09
        module temperature: 65.71 C Voltage: 3.27 Volts
        RX: 0.51 mW (-2.84 dBm) TX: 0.60 mW (-2.21 dBm)
cc1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=ec07bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,LINKSTATE,RXCSUM_IPV6,TXCSUM_IPV6>
        ether 00:07:43:XX:XX:X8
        hwaddr 00:07:43:XX:XX:X8
        nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
        media: Ethernet 10Gbase-SR <full-duplex,rxpause,txpause>
        status: no carrier
        supported media:
                media 10Gbase-SR mediaopt full-duplex,rxpause,txpause
                media 10Gbase-SR mediaopt full-duplex,rxpause
                media 10Gbase-SR mediaopt full-duplex,txpause
                media 10Gbase-SR mediaopt full-duplex
                media 1000baseSX mediaopt full-duplex,rxpause,txpause
                media 1000baseSX mediaopt full-duplex,rxpause
                media 1000baseSX mediaopt full-duplex,txpause
                media 1000baseSX mediaopt full-duplex
        plugged: SFP/SFP+/SFP28 10G Base-SR (LC)
        vendor: JDSU PN: PLRXPLSCS4342B SN: CJ28XXXXX DATE: 2018-07-09
        module temperature: 63.31 C Voltage: 3.22 Volts
        RX: 0.00 mW (-25.69 dBm) TX: 0.58 mW (-2.34 dBm)

I noticed the cc0 port is literary running hot at 65.71 °C (150.3 °F). The cc1 port is slightly cooler at 63.31 °C (146.0 °F).

#notsponsored

Published by

Trond Endrestøl

I stopped counting my age years ago. Personal interests besides computers and computer networks include, but are not limited to, astronomy, comics, music, and science (fiction).

Leave a Reply

Your email address will not be published. Required fields are marked *